Threadripper 1950X issues, 16 cores/32 threads

Bug reports go here.
Azmodes
Posts: 15
Joined: Sat Sep 08, 2018 12:27 pm

Threadripper 1950X issues, 16 cores/32 threads

Post by Azmodes » Wed Apr 10, 2019 4:02 pm

Is there some issue with a higher number of threads used? Whenever I transcode MP3s on my 1950X, it starts out fine, but after a couple of seconds everything slows down considerably (>20% CPU load). I've tried reducing the number of simultaneous jobs to the number of physical cores (32->16), but the problem remains. The program (XRECODE3) also becomes almost completely unresponsive during the conversion; i.e. it continues showing progress, but moving the window around is impossible, I can't move it to the foreground after minimzing, etc.

Is there some kind of bottleneck I'm unaware of?
Last edited by Azmodes on Wed Apr 10, 2019 4:22 pm, edited 1 time in total.

admin
Site Admin
Posts: 465
Joined: Wed Nov 17, 2010 12:56 pm

Re: Threadripper 1950X issues, 16 cores/32 threads

Post by admin » Wed Apr 10, 2019 4:16 pm

Please try the following:
- Under MP3 Setting set it to Manual
- Then click Test button
What output do you get?

Azmodes
Posts: 15
Joined: Sat Sep 08, 2018 12:27 pm

Re: Threadripper 1950X issues, 16 cores/32 threads

Post by Azmodes » Wed Apr 10, 2019 4:19 pm

Code: Select all

External encoder was configured properly
Details are below:



C:\windows\system32\cmd.exe /D /C  type "C:\Users\Dani\AppData\Local\Temp\XRECODE3\659796__19282_0.wav" | "C:\Program Files\xrecode3\bin\x64\lame.exe"  -r -s 44100 --bitwidth 16   - "C:\Users\Dani\AppData\Local\Temp\XRECODE3\659796__19282_1.mp3" 1> "C:\Users\Dani\AppData\Local\Temp\XRECODE3\659796__19282_2.txt" 2> "C:\Users\Dani\AppData\Local\Temp\XRECODE3\659796__19282_3.txt"



Assuming raw pcm input file
LAME 3.100 64bits (http://lame.sf.net)
CPU features: SSE (ASM used), SSE2
Using polyphase lowpass filter, transition band: 16538 Hz - 17071 Hz
Encoding <stdin> to C:\Users\Dani\AppData\Local\Temp\XRECODE3\659796__19282_1.mp3
Encoding as 44.1 kHz j-stereo MPEG-1 Layer III (11x) 128 kbps qval=3

admin
Site Admin
Posts: 465
Joined: Wed Nov 17, 2010 12:56 pm

Re: Threadripper 1950X issues, 16 cores/32 threads

Post by admin » Wed Apr 10, 2019 4:50 pm

OK, does it work if you select "Use lame_enc.dll" under MP3 Settings?

Azmodes
Posts: 15
Joined: Sat Sep 08, 2018 12:27 pm

Re: Threadripper 1950X issues, 16 cores/32 threads

Post by Azmodes » Wed Apr 10, 2019 4:56 pm

No, same problem.

admin
Site Admin
Posts: 465
Joined: Wed Nov 17, 2010 12:56 pm

Re: Threadripper 1950X issues, 16 cores/32 threads

Post by admin » Wed Apr 10, 2019 5:00 pm

Is the same problem with other output formats as well?

Azmodes
Posts: 15
Joined: Sat Sep 08, 2018 12:27 pm

Re: Threadripper 1950X issues, 16 cores/32 threads

Post by Azmodes » Wed Apr 10, 2019 5:02 pm

I've tried WMA and WAV. Pretty much the same issue (and even worse CPU usage with WAV).

admin
Site Admin
Posts: 465
Joined: Wed Nov 17, 2010 12:56 pm

Re: Threadripper 1950X issues, 16 cores/32 threads

Post by admin » Wed Apr 10, 2019 5:10 pm

Does it help if you disable this option https://imgur.com/a/4X14fK2?

Azmodes
Posts: 15
Joined: Sat Sep 08, 2018 12:27 pm

Re: Threadripper 1950X issues, 16 cores/32 threads

Post by Azmodes » Wed Apr 10, 2019 5:15 pm

Wow YES

100% loaded all the way, even with 32 threads in tandem. Thank you!

That's kinda weird, though. :P

admin
Site Admin
Posts: 465
Joined: Wed Nov 17, 2010 12:56 pm

Re: Threadripper 1950X issues, 16 cores/32 threads

Post by admin » Thu Apr 11, 2019 7:59 pm

Could you, please, try this version with the original progress window settings -http://xrecode.com/test/setup_xrecode3_ ... t_1.91.exe?

Post Reply