TAK file doesn't decode on x64

Bug reports go here.
Post Reply
Posts: 1
Joined: Thu Jul 02, 2020 2:29 am

TAK file doesn't decode on x64

Post by anthos »

Hi, I appreciate the effort you do to maintain this amazing tool. I have an "old" TAK file that I was shure I could play with the standard DirectShow filter I install with some codec pack, but it didn't play, so I tried VLC x64 without success. Then I tried to decode it with XRECODE3 x64 1.102 and it gave me an error message:


And this is the log:

1/07/2020 21:38:41: ERROR: C:\Users\Home\Desktop\unripe hero.tak : ff_decode_audio Error while decoding (-1163346256) : Not yet implemented in FFmpeg, patches welcome
1/07/2020 21:38:41: ERROR: C:\Users\Home\Desktop\unripe hero.wav : DecodeAudio failed with error ERROR_DECODE_ERROR (-4). File might be unsupported or corrupted.

There was no error when I tried the x86 version, but I wanted to report it because nowadays anyone would use the x64 version and not figure what happens. Thank you for reading.
Site Admin
Posts: 595
Joined: Wed Nov 17, 2010 12:56 pm

Re: TAK file doesn't decode on x64

Post by admin »

Here's the update to try - https://xrecode.com/test/setup_xrecode3 ... _1.103.exe
If it doesn't work, please send that .tak file to xrecode@gmail.com (you could use https://wetransfer.com).
Post Reply